HomeForumsPanoPress SupportWarning: curl_setopt

Tagged: , ,

This topic contains 25 replies, has 5 voices, and was last updated by  killer000sp 2 years, 11 months ago.

Viewing 20 posts - 1 through 20 (of 26 total)
  • Author
    Posts
  • #2087

    Monch
    Participant

    Sorry use translator

    after upgrading to version 1.1 I get this message

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /membri/arbich/blog/wp-content/plugins/panopress/panopress.php on line 157

    My site   http://arbich.altervista.org/blog/

    if someone helps me with  ciao

    Monch

    #2089

    Omer Calev
    Keymaster

    hey,

    if you have access to your php.ini, try to set safe_mode = Off, if it’s already off, change open_basedir settings.

    note: safe_mode has been deprecated as of PHP 5.3.0

    or contact your host service tech support with this info.

    omer

    #2090

    Monch
    Participant

    I feel I understand

     

    grazie Omer

    #2091

    Monch
    Participant

    use translator

    made this response

    alemoppo  Moderator Join Date: 24-08-2008 Location: PU Posts: 4.780

    On altervista not edit the php.ini, because there is only one server in php.ini, and many sites. If you had the chance to change it, you would modify the settings of the other sites hosted on this server.

    http://forum.it.altervista.org/wordpress/179313-attenzione-curl_setopt.html#post1010301

    #2092

    Sam Rohn
    Keymaster

    theoretically you should be able put php.ini in your root directory and only affect your own site

    but i believe altervista is a free hosting service which offers limited php support, so some wordpress plugins and other php code may not function properly on altervista sites

    you might want to consider moving to a proper paid hosting service w full php support

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #2094

    Monch
    Participant

    ok grazie

    I consider your advice

    but I have to try something cheap are an amateur with little chance

    ciao ed ancora grazie

    #2095

    Monch
    Participant

    but what hosting to choose??

    What should I watch for making a good choice

    #2097

    Sam Rohn
    Keymaster

    @omer uses dreamhost, i use hostgator, either one should cost you like $5 – $10 per month

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #2102

    Monch
    Participant

    grazie I give a look at

    ciao

     

     

     

    #2103

    nzfoto
    Participant

    Have the same issue on paid hosting. I do not have access to the php.ini.

    Is there an over ride for this or if I install version 1 to see if that causes the same error?

    Thanks

    #2104

    Sam Rohn
    Keymaster

    @nzfoto, yes, please try 1.0 and let us know if it gives the same error

    also post a link to your page w the error

    thanks

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #2105

    nzfoto
    Participant

    Thanks Sam, do you have a download link for v1?

    Regards Paul

    #2106

    nzfoto
    Participant

    Thanks Sam, do you have a download link for v1? Regards Paul

    Found a copy of v1.0b1 on file

    CURL error gone, Get a different error

    *Error

    The width value is incorrect*

    #2107

    nzfoto
    Participant

    Hi Sam

    Sorry for all the posts, there does not seem to be an edit mode on the forum posts.

    Have got v1.0b1 working fine on my server for now.

    To remove the width error is used the following data and now works well.

    [ pano file=”http://www.mydomain.com/wp-content/uploads/360cottage.swf”  preview=”http://www.mydomain.com/wp-content/uploads/360cottage.jpg” width=”900″ height=”500″ ]

     

    Will stick with the older version till I can get my host to amend the safe mode or your next version will work around this.

    Thanks Sam and Omer for the work you guys have done in making this plugin

    #2108

    Monch
    Participant

    use translator

    I’m sorry,

    But where you say: (To remove the error in width is used, the following data and now it works fine.)  I see only empty space

    I can not see the data

    I’m okay even private message    angmonch@tin.it

    Ciao

    #2109

    Monch
    Participant

    I understand it now (I have a delayed action)

    Sam, you have a download link for the v1 for me to be here I can not download hello thanks

    #2110

    Sam Rohn
    Keymaster

    sorry, you can grab panopress 1.0 here if you are seeing these errors

    http://downloads.wordpress.org/plugin/panopress.1.0.zip

    if you are going back from 1.1 to 1.0 you will need to reset width and height w no % or px as @nzfoto noted above

    so if you are getting errors w 1.1, try 1.0 and let us know if you see the same errors

    post edit limit is 30 min, you should be able to edit your post within that time window ?

    THANKS for the feedback everyone, we will get these errors sorted asap 🙂

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #2113

    Monch
    Participant

    use translator

    I loaded 1.0 Pano press received error

    Following instructions modified width height

    new error

    Gone settings PanoPress

    updates that gave me error in width height option.

    Made of new updates as ok

    Displayed pages no error

    Without modifying the same settings as always.

    send example

    so goes

    the only way I can always run PanoPress

     

    ciao

    #2114

    Monch
    Participant

    sorry forgot the usual example here it is
    [ pano file=”http://arbich.altervista.org/blog/wp-content/uploads/panox/calabria/dino1/dino1_out.swf”]

    #2117

    Sam Rohn
    Keymaster

    i edited your shortcode so we could see the code and not the embed, i just added a space after first bracket to stop the shortcode from rendering

    even though the direct link to this pano works properly and it SHOULD work fine in panopress but it is not displaying in the embed code below, so there may be other issues w altervista, again, i would recommend finding a more reliable hosting service

    shortcode example (space after first bracket to stop shortcode from rendering here)

    [ pano file=”http://arbich.altervista.org/blog/wp-content/uploads/panox/calabria/dino1/dino1_out.swf”]

    embed example (this should work but does not display the pano)


    Error
    Javascript not activated

    otherwise, we are looking into the other errors listed and hope to have a fix soon

    thanks

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

Viewing 20 posts - 1 through 20 (of 26 total)

You must be logged in to reply to this topic.