HomeForumsPanoPress Support'Replay' button an option?

This topic contains 1 reply, has 1 voice, and was last updated by  joel 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3727

    joel
    Participant

    Wordpress Version: 4.9.1
    Wordpress Theme: Divi
    Panopress Version: 1.3
    Panorama Player: Panotour Pro

    Website URL: http://www.cloud9.com.au
    Website Panorama: http://www.cloud9.com.au/our-services/panorama/

    Panopress shortcodes..


    Error
    Javascript not activated


    Error
    Javascript not activated


    Error
    Javascript not activated


    Error
    Javascript not activated


    Error
    Javascript not activated

    Panopress settings are as follows:

    Style: Show Play Button (Yes)
    Panobox: Open panoramas in Panobox (No – Unticked)
    Panobox: Open image galleries in Panobox (No – Unticked)
    Global Viewer: Use Global Viewer (No – Unticked)
    Performance: Only one active panorama per page for: ALL DEVICES
    Flash Window Mode: Auto (Both)

    Background…

    I’m using Slider Revolution as the method for displaying 5 different panoramas, as shown on the Panorama page URL provided. I’ve got one primary panorama loaded up in the slider, with thumbnails underneath linked to 4 additional panoramas.

    I built the site on my development server (hosted by Bluehost). In development, all 5 panoramas loaded promptly and the ‘slider’ worked beautifully. It’s a nice, neat way to display the panos and this worked nicely, albeit only on my development server!!

    After migrating the site to a live environment, I noticed performance issues with the slider. In short, the clients shared hosting server didn’t want to load all panos, and subsequently I was seeing a black screen on a ‘hit and miss’ basis.

    To ensure that all 5 panoramas could remain, I changed the panopress setting to only show one active panorama for all devices.

    This fixed the problem…. sort of ! The problem as it stands is best outlined as follows:

    – User visits the panorama page.
    – First panorama loads nicely.
    – User can select the 2nd, 3rd, 4th or 5th panoramas by clicking corresponding thumbnail.
    – When 2nd, 3rd, 4th or 5th panoramas are selected, user must press the ‘play’ button.
    – User can then click thumbnail for all other unwatched panos and they will display a play button, which will load and play the respective panorama when clicked. Hence… all good!!

    If user clicks a thumbnail for a pano they’ll already watched, however, the pano will again display as a black screen though no play button will appear. Hence, any pano that has been previously watched cannot be watched again unless the page is loaded/refreshed.

    Is there any way to ensure that the play button is displayed again when a user goes back to a previously watched panorama ? If this could be achieved, the user experience would be considerably better.

    Any advice you can provide is much appreciated. Thanks for taking the time to read the above and consider my problem.

    Cheers,

    Joel

    #3728

    joel
    Participant

    Bugger…. sorry! I included the pano shortcodes in my OP.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.