HomeForumsPanoPress SupportI have tried everything, but it doesn't work. [Resolved, bad quote marks]

This topic contains 4 replies, has 3 voices, and was last updated by  Sam Rohn 1 year, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3550

    AnePoe
    Participant

    Hello!

    Please, I have no more idea, what could be the reason why the panorama is not displayed.

    I have tried a default theme – it doesn’t work.
    I have disabled all plugins – it doesn’t work.

    Link to the wordpress-Website:
    http://orthopaedie-schlosscarree.com/wordpress/die-praxis/

    Direct link to the panorama outside of WordPress:
    http://orthopaedie-schlosscarree.com/wordpress/wp-content/uploads/panoramas/tour_3/index.html

    An example of the shortcode that is failing:
    pano file=”http://orthopaedie-schlosscarree.com/wordpress/wp-content/uploads/panoramas/tour_3/index.html”

    I am using latest versions: WordPress 4.5.3 and Panopress 1.2

    ### Which panorama player are you are using (Krpano, Pano2VR, PanoTour Pro, etc) ?
    I don’t know – perhaps this is the problem? In a seperate browser-window the panorama works perfectly. Only in wordpress it doesn’t work. Thought it works with Flash…? Or do I have to install more plugins?

    The path is correct, I have controlled it several times.

    Do you have an idea, why it doesn`t work? Is wordpress the problem?

    Thank you so much in advance, I am really frustrated after spending so much time.

    Best wishes,
    Anette

    #3551

    Sam Rohn
    Keymaster

    howdy

    i just tested your code and it failed for me too, but nothing wrong i can see, direct link works, path is correct etc, but pano does not show up in embed

    so something else on your end must be interfering, if you have already tested with default wp theme and no other plugins, it may be some other server configuration or .htaccess redirection issue etc which prevents site content from being embedded in panopress, see if you have any odd rules in htaccess files or other cpanel config etc

    alternatively, you could try using an iframe to embed your pano, which was made with krpano – http://krpano.com

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #3552

    AnePoe
    Participant

    Dear Sam,
    thank you very much for taking the time to search for the error.
    I am going to try your tips soon.
    Many thanks!
    Best wishes,
    Anette

    #3553

    Martin
    Participant

    Hi Anette

    I just copied your panopress parameters over to my test page and got the same result as you got (404 page not found) but I think I may know what it is

    I think it’s the problem of the wrong kind of inverted commas around the pano parameter string

    when I changed them to the right kind (shift/2 on my keyboard) it all worked fine

    best
    Martin

    #3555

    Sam Rohn
    Keymaster

    thanks martin, good catch 🙂

    as he said, bad quote marks are the culprit here, normal quotes work fine

    from the FAQ – http://www.panopress.org/forums/topic/panopress-troubleshooting-faq-read-me/

    Curly Quotes vs Straight Quotes
    Always double check the quote symbols in your shortcode, make sure you are using only straight quotes [" "] and not any kind of smart or curly quotes [“ ”], curly quotes will cause the shortcode to fail

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.