HomeForumsPanoPress SupportError 403 when pressing the play button

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  TheRiddler1982 1 month, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #3650

    TheRiddler1982
    Participant

    Hi PanoPress Team,

    for a long time I have strange error and I cannot figure out, what is causing it. It only affects panoramas.

    I am using Debian 8 with WordPress 4.5 and the latest Panopress plugin. I have full access to the root server.

    The problem:

    Please visit e.g. https://ziin.de/panorama/landschaften/nordamerika-landschaften/oregon/

    When you press the play button, a 403 error (forbidden) pops up.

    I have looked in my logs, the only thing I found was

    Cannot serve directory /var/www/virtual/ziin.de/htdocs/wp-content/uploads/panoramas/Landschaften/Nordamerika/Westkueste/USA/Oregon/Cascades_Locks/: No matching DirectoryIndex (index.php,index.html,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

    as well as

    "GET /wp-content/uploads/panoramas/Landschaften/Nordamerika/Westkueste/USA/Oregon/Cascades_Locks/20140916_214457_Nordamerika_Westkueste_Panorama_Cascades_Locks_0001.html?base=https://ziin.de/wp-content/uploads/panoramas/Landschaften/Nordamerika/Westkueste/USA/Oregon/Cascades_Locks/& HTTP/2.0" 403 551 "https://ziin.de/panorama/landschaften/nordamerika-landschaften/oregon/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0"

    When I try to access the link directly

    https://ziin.de/wp-content/uploads/panoramas/Landschaften/Nordamerika/Westkueste/USA/Oregon/Cascades_Locks

    I get the same error. Usually, I do not want bots or users to browse my directories.

    What do I have to change to make that working?

    I have already added

    <Directory /var/www/virtual/ziin.de/htdocs>
    Options FollowSymLinks
    DirectoryIndex index.html index.php
    AllowOverride All
    <If “%{REQUEST_FILENAME} =~ /\.ph(?:p[3457]?|t|tml)$/ && -f %{REQUEST_FILENAME}”>
    SetEnvIfNoCase ^Authorization$ “(.+)” HTTP_AUTHORIZATION=$1
    SetHandler proxy:fcgi://ziin.de
    </If>
    DirectoryIndex index.html index.xhtml index.htm index.php
    Require all granted
    </Directory>

    in my site’s config file.

    A direct working link to my panorama is the following:

    https://ziin.de/wp-content/uploads/panoramas/Landschaften/Nordamerika/Westkueste/USA/Oregon/Cascades_Locks/20140916_214457_Nordamerika_Westkueste_Panorama_Cascades_Locks_0001.html

    Thanks for your help!

    Bye,
    Sven

    #3651

    Omer Calev
    Keymaster

    Hi Sven,

    Please post the shortcode you are using.

    Omer

    #3652

    TheRiddler1982
    Participant

    Hi Omer,

    thanks for your reply.

    Here is a typical shortcode I am using in my articles:

    pano file=”Landschaften/Nordamerika/Westkueste/USA/Kalifornien/Point_Lobos_State_Natural_Reserve/20140929_213337_Nordamerika_Westkueste_Panorama_Point_Lobos_State_Natural_Reserve_0002.html” width=”100%” height=”160px” panobox=”off” button=”on” preview=”Landschaften/Nordamerika/Westkueste/USA/Kalifornien/Point_Lobos_State_Natural_Reserve/20140929_213337_Nordamerika_Westkueste_Panorama_Point_Lobos State_Natural_Reserve_0002.jpg”

    Sven

    #3653

    TheRiddler1982
    Participant

    For some reason my answer is not shown.

    Here is my code:

    pano file=”Landschaften/Nordamerika/Westkueste/USA/Kalifornien/Point_Lobos_State_Natural_Reserve/20140929_213337_Nordamerika_Westkueste_Panorama_Point_Lobos_State_Natural_Reserve_0002.html” width=”100%” height=”160px” panobox=”off” button=”on” preview=”Landschaften/Nordamerika/Westkueste/USA/Kalifornien/Point_Lobos_State_Natural_Reserve/20140929_213337_Nordamerika_Westkueste_Panorama_Point_Lobos State_Natural_Reserve_0002.jpg”

    Sven

    #3654

    Omer Calev
    Keymaster

    Try using straight quotes [" "] not smart or curly quotes [“ ”] for all shortcode parameters and make sure you don’t have spaces or other special characters in your URLs.

    Omer

    #3655

    TheRiddler1982
    Participant

    Didn’t work, I already had straight quotes (the forum just made it curly :-)). Any other ideas? Would you need access to my server?

    #3656

    Omer Calev
    Keymaster

    1. Try full URL with http://

    2. Try simpler configuration, preferably on another server – basic theme, disable other plugins and no fancy Apache rules. see if you can get it to work and isolate the source of the problem.

    Would you need access to my server?

    no need for that yet 🙂

    Omer

    #3657

    TheRiddler1982
    Participant

    Hi again,

    sorry for keeping you waiting. For some reason the problem disappeared, than it came back, now it’s gone again. I’ll observe that for a while and come back to you.

    Thanks,
    Sven

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.