HomeForumsPanoPress SupportPanoPress 1.0 release – Update from earlier version problems ?

This topic contains 48 replies, has 6 voices, and was last updated by  Omer Calev 4 years, 1 month ago.

Viewing 20 posts - 1 through 20 (of 49 total)
  • Author
    Posts
  • #1497

    Arndt Büthe
    Participant

    First of all – I´m using this plugin since it was developed and THANKS for sharing it!

    After updating to v1.0 I have strange path issues with the html version. SWF plays just fine (krpano crafted tour) and when loding the same xml via html5 enabled device  I get 404 errors with the html5 plugins, i.e. gyro.js, textarea.js. Relative and absolute path tried – no solution.

    Example: http://panoteam.de/blog/?p=189

    Embed code used:

    [  pano f=”http://panoteam.de/…/tour.xml” preview=”http://panoteam.de/…/leverkusen_1000x350.png” w=”640″ h=”480″]

    This used to play well before the update. Am I missing something?

    Cheers, Arndt

     

    #1498

    Arndt Büthe
    Participant

    Uhhhh example was:

    [pano f="http://panoteam.de/...../tour.xml" preview="http://panoteam.de/...../leverkusen_1000x350.png" w="640" h="480"]

    #1499

    Arndt Büthe
    Participant

    OK – seems it´s not possible to post URLs here.. You can copy&paste them from the trash above .)

    #1500

    Sam Rohn
    Keymaster

    the update shouldnt break anything, and has not caused any probs in our testing

    wordpress embeds are live in this forum, so posting a shortcode that fails will render an error mssg, which is a bit confusing i must admit, we will get that sorted asap – meanwhile i fixed your posts

    posting a url is working fine, can you post a working link to your files ? the links you posted were broken, hence the errors…

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1501

    Arndt Büthe
    Participant

    The embed uses was:

    The url above uses this excact embed.. works for swf / not for html5. I used relative paths before i.e. Leverkusen/tour.xml and that did work formerly. Still works for swf, but not for html5..

    [  pano f=”http://panoteam.de/blog/360/Leverkusen/tour.xml” preview=”http://panoteam.de/blog/360/Leverkusen/leverkusen_1000x350.png” w=”640″ h=”480″]

    #1502

    Sam Rohn
    Keymaster

    typically this sort of thing is caused by path issues in your xml file, you have to either use something like the safari activity inspector to see where the files are trying to load from and alter oyur xml accordingly, OR, you can just go into your xml and make sure you have %SWFPATH% appended to the plugin paths, etc

    but the easy thing to do is to just embed as html, like this

    [*pano file=”http://panoteam.de/blog/360/Leverkusen/” preview=”http://panoteam.de/blog/360/Leverkusen/leverkusen_1000x350.png” w=500 h=300]

    remove the *, i clearly need to sort out some issue w posting code to this forum…


    Error
    Javascript not activated

    just checked on my iphone, works fine

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1503

    Sam Rohn
    Keymaster

    i had to update that last post a few times so the code would show properly in the example, just remove the * and it will work as shown

    you can embed as either .html file or any url ending in a slash

    file=http://www.domain.com/path/my-pano/my-pano.html

    or

    file=http://www.domain.com/path/my-pano/

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1504

    Arndt Büthe
    Participant

    When I try to use the htm embed I get an error from wordpress which is why I didn´t use this syntax before. Not sure where it comes from though..

    Error

    Please enter file name or URL

     

    html output reads like this:

     

    <!– PanoPress [1.0] –>

    <script type=”text/javascript”>

    pp_oppp=false;

    pb_options={“fullscreen”:true,”fade”:true,”animate”:true,”shadow”:true,”width”:”640″,”height”:”480″,”style”:{“box”:”pb-light”,”overlay”:”pb-light-overlay”}};

    </script>

    <script type=”text/javascript” src=”http://panoteam.de/blog/wp-content/plugins/panopress/js/panopress.js?v=1.0“></script>

    <link rel=”stylesheet” type=”text/css” media=”all” href=”http://panoteam.de/blog/wp-content/plugins/panopress/css/panopress.css?v=1.0” />

    <!– /PanoPress –>

     

    #1505

    Sam Rohn
    Keymaster

    hmm, if you enter the paths in the shortcode exactly as i have shown it should work, its working fine here, we are using panopress 1.0 release and wordpress 3.4.2, make sure you are not copy/pasting any odd or invisible characters etc ?

    always best to use the wordpress html editor rather than the visual editor if you are getting odd results, look at your shortcode using the html editor and make sure everything is as it should be

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1506

    Fraser MacInnes
    Participant

    Thanks for the Panopress update. I’m now able to open tuors in Internet Explorer 8 which I couldn’t before, however, when I close a tour (using X) I get a black screen which I can only get out of by pressing the back button on the browser.

    Any thoughts?

    Thanks,

    Fraser

    #1507

    Arndt Büthe
    Participant

    Ok, it seemed to be indeed a problem with the visual editor.. Nevermind the trouble, I´m totally happy with panopress once again 🙂

     

    Now – where is that paypal donate button when you need it?

    #1508

    Rui Pedro
    Participant

    hi all, and thanks too

    just upgraded… and downgraded…

    my website stopped showing panoramas

    http://www.panoramapalace.com

    i can i help you (and you help me) to find the issue?

    thanks

     

    #1509

    Sam Rohn
    Keymaster

    arndt, glad you got it sorted out  🙂

    rui, your site if working fine for me ?

    fraser, we would need to see a link to your site to try to determine what might be going wrong…

    there is really no way for us to determine what might be causing a specific problem without seeing a working link to a site running panopress 1.0, so if anyone is apparently having probs after the 1.0 update, please post a link to your site running [PP] 1.0

    it is also always a good idea to check things out on different machines if possible, rule out local browser config, etc

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1510

    Rui Pedro
    Participant

    yep.. it is working fine because i downgraded 😀

    can we agree a “time window” tomorrow and i’ll upgrade and you’ll check?

    thanks so much

    #1511

    Fraser MacInnes
    Participant

    Sam,

    Link to my site is:

    http://www.360virtualimage.com/portfolio/

    Tours open and close fine in all other browsers (Firefox, Safari & Chrome), IE8 is the only one I’m having issues with. Before yesterday’s Panopress update tours wouldn’t open at all in IE8, now they open fine but on closing I’m left with a black screen. I’ve tried this on a PC and a laptop both running IE8.

    Grateful for any help.

    Thanks,

    Fraser

     

    #1512

    Sam Rohn
    Keymaster

    rui, it is difficulty for me to predict a time tomorrow that i will be able to get to this, but i will prob be able to look at it in the next 4 hours or so tonight (before midnight EST or so)

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1513

    Sam Rohn
    Keymaster

    Sam, Link to my site is: http://www.360virtualimage.com/portfolio/ Tours open and close fine in all other browsers (Firefox, Safari & Chrome), IE8 is the only one I’m having issues with. Before yesterday’s Panopress update tours wouldn’t open at all in IE8, now they open fine but on closing I’m left with a black screen. I’ve tried this on a PC and a laptop both running IE8. Grateful for any help. Thanks, Fraser

    fraser, i just checked your site on IE8 and i see your problem, opening a pano in a panobox and then closing the pano results in  a black window like you described

    but this page on my own site works fine in IE8 using panopress 1.0 release, closing panobox works properly

    http://www.samrohn.com/360-panorama/manhattan-rooftop/

    so it is likely a prob w your theme or somesuch, leave it as is for now and omer should be able to have a look at this soon and figure out what may be happening

    thanks 🙂

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1525

    Pitch Art
    Participant

    Hi,

    I’ve a problem since the update, my pano does’nt work, the preview it’s ok but when I click on for open the Pano not work, can you help me on this problem ? This is the link for see that in action

    http://www.studiopitchart.com/visitesvirtuelles/

    #1526

    Sam Rohn
    Keymaster

    howdy

    pitch, i see the prob on your site, the panobox does not open entirely and does not display any content inside the panobox

    as we’ve had a few such reports today we will be looking into this asap

    just out of curiosity, did you update from panopress 0.9 or 1.0b1 ?

    thanks

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

    #1528

    Sam Rohn
    Keymaster

    btw, anyone updating from panopress 0.9 to panopress 1.0 final should go into their panopress settings and make sure everything looks as it should, then resave your panopress settings in wordpress admin even if you have not changed anything, this may resolve some of the problems recently posted by pitch, rui & fraser

    please let us know if it works

    sam

    Sam Rohn :: New York City
    360° Panoramic Photography :: www.samrohn.com
    Location Scout :: www.nylocations.com

Viewing 20 posts - 1 through 20 (of 49 total)

You must be logged in to reply to this topic.